Jump to content


Photo

Running Minecraft With 64-Bit Java


  • Please log in to reply
17 replies to this topic

#1 Scare

Scare

    S.P.E.C.T.R.E.

  • Administrators
  • 2945 posts

Posted March 03 2011 - 04:35 PM

I was crashing quite frequently when I was using minecraft.exe with win7_64. Thanks to neh, I switched to using 64-bit java, and I crash a lot less now.

Here's how you do it:
Using 64-bit internet explorer (firefox is only 32-bit, make sure you use the 64-bit shortcut in the start menu), go to Sun's Java download page. It should automatically detect that you're on a 64-bit OS and offer up 64-bit java. Run the installer, it should install into Program Files\Java by default.

Download the minecraft .jar file (listed under linux/other) from the download page. Also copy the command line options, you'll need that.

Create a windows shortcut to run minecraft. Set "Start in" to be where the .jar file is. I moved mine to c:\Users\Scare\Minecraft
Set Target to
"c:\Program Files\Java\jre6\bin\java.exe" -Xmx1024M -Xms512M -cp Minecraft.jar net.minecraft.LauncherFrame
You can also use Change Icon on it and select your old minecraft.exe to copy the program's icon.

If you want to add it to steam as well, you can point steam at the windows shortcut.

I haven't tried increasing the memory yet, but I think you can safely increase the -Xms parameter to something bigger.
Posted Image

#2 ratty

ratty

    Double rainbow all the way

  • Ratty
  • 13284 posts

Posted March 03 2011 - 04:42 PM

Download the minecraft .jar file (listed under linux/other) from the download page. Also copy the command line options, you'll need that.


I just want to highlight that part, I fucked up thinking I could just point it at %appdata%\.minecraft\bin but NOPE. You gotta download the jar from http://www.minecraft...d/minecraft.jar

Also note you can set the amount of memory if you want to tweak that, just change the -Xmx1024M part, the 512M is like "starting memory".

#3 William Dogood

William Dogood

    I post a lot!

  • Administrators
  • 5058 posts

Posted March 03 2011 - 06:21 PM

I tried doing this last night but couldn't find the download link. Scare got me all sorted out about an hour ago.

There was a specific reason I was trying to get 64bit Java for Minecraft, and I can't remember what it is now.
5:01 PM - Baker: Mfw old woman with no bra and loose fitting shirt
5:02 PM - Baker: Pretty sure I'm 1 percent gayer as a result. For a grand total of 1 percent.
Posted Image

#4 Gadgeteer

Gadgeteer

    Fully Automated

  • Members
  • 814 posts

Posted March 04 2011 - 12:38 AM

A note about Steam shortcuts: although it is not possible to lunch java with Minecraft.jar though steam, you can still run it commands in the "target" field under properties. So you still need the windows shortcut, but you can pass it your login info though the Steam shortcut instead of the windows one.

The jar file also seems to give me marginally better performance, so thanks!

Tomorrow's agenda: play with Xmx/Xms settings. :lol:
Go Go Gadget Signature!
Posted Image

#5 Draythan

Draythan

    My Power Pee will pierce the heavens!

  • TF2 Admins
  • 4651 posts

Posted March 04 2011 - 05:03 AM

Wow, didn't know there was a x64 version of java... and it goes with a better fps than with the x86 version.
I said it once, and I'll say it twice or as many times as needed: I love you all *v*
Fuck it, I'm out of here.

#6 QuaintHazard

QuaintHazard

    Hazardly Hazardous

  • TF2 Admins
  • 3737 posts

Posted March 04 2011 - 08:10 AM

Oh, theres a x64 version? I wish I knew that earlier.
Is the performance of the 64-bit that much better than a 32-bit on a 64-bit OS?
Posted Image

#7 Scare

Scare

    S.P.E.C.T.R.E.

  • Administrators
  • 2945 posts

Posted March 04 2011 - 11:09 AM

Yes, it is. To make 32 bit java work on 64 bit, they introduced hot-spot VM technology. It's a 32-bit virtual machine in your java virtual machine, so that it works. But like all emulators, takes a performance hit since it goes through another layer of translation, and has yet another angle for nasty things like memory leaks and bugs.

I think the reason they don't roll the native version by default is because of browsers - majority are still 32-bit. As a result, the java browser plugin is also 32 bit, which requires the 32 bit jvm.
Posted Image

#8 QuaintHazard

QuaintHazard

    Hazardly Hazardous

  • TF2 Admins
  • 3737 posts

Posted March 04 2011 - 11:36 AM

Oh, thats so cool, I never knew Java did that on x64.
I will be sure to get the 64-bit version when I get home. Thank you scare. :)
Posted Image

#9 Milk™

Milk™

    -

  • Scrimmer
  • 1894 posts

Posted March 04 2011 - 12:43 PM

Yeah, I'm definitly going to take advantage of this being a W7 x64 guy myself. Thanks for all the information. I'll put it to good use this weekend.

#10 KaiserYoshi

KaiserYoshi

    You can't defeat me because I've got magic aaaaaargh.

  • Members
  • 87 posts
  • Scout, Engineer, Sniper, Medic

Posted March 05 2011 - 07:20 PM

Just so I'm clear, this trick won't work with the minecraft.jar I already have? Do I replace my existing minecraft.jar with the one in the download or save it somewhere else? Will the new minecraft.jar break if I install mods in it?
Posted Image

#11 Neh

Neh

    Hiya!

  • Administrators
  • 3244 posts

Posted March 05 2011 - 07:36 PM

the minecraft.jar within your appdata folder is the game file, but it won't run by itself. It needs a launcher. That's what Minecraft.exe is for. However, not everyone can run an exe file, so there is a Minecraft.jar launcher as well. That is what you need to download, and it can be run from anywhere.

#12 ratty

ratty

    Double rainbow all the way

  • Ratty
  • 13284 posts

Posted March 05 2011 - 10:43 PM

I just want to highlight that part, I fucked up thinking I could just point it at %appdata%\.minecraft\bin but NOPE. You gotta download the jar from http://www.minecraft...d/minecraft.jar



#13 KaiserYoshi

KaiserYoshi

    You can't defeat me because I've got magic aaaaaargh.

  • Members
  • 87 posts
  • Scout, Engineer, Sniper, Medic

Posted March 06 2011 - 07:58 PM

No change in performance. How disappointing.
Posted Image

#14 Swink91

Swink91

    Newbie

  • Members
  • 1 posts

Posted October 08 2011 - 05:21 AM

I must be a real idiot, i usually dont have any problems with stuff like this but would someone help me to get this to work?

I downloaded the .jar file and copied the command line, but really didnt understand where to put any of it,.

After downloading java 64 bit however i noticed from my task manager that without following the rest of the steps minecraft is no longer using java 32 bit, but javaw.

I´m happy for any help or guidelines i can get, cheers!

#15 ratty

ratty

    Double rainbow all the way

  • Ratty
  • 13284 posts

Posted October 08 2011 - 09:56 AM

It would say javaw.exe even with 32-bit, but I did notice myself that it is using 64-bit by default, as the javaw.exe process doesnt have a *32 next to it in the task manager.

#16 jdrrrr

jdrrrr

    Newbie

  • Members
  • 1 posts
  • Sniper

Posted January 08 2012 - 12:39 PM

thank you for the help and i changed it a little but the target i put in was

"c:\Program Files\Java\jre6\bin\javaw.exe" -Xmx1024M -Xms512M -cp minecraft.exe net.minecraft.LauncherFrame


and now it works perfectly Thank you so much

#17 ace

ace

    Newbie

  • Members
  • 1 posts

Posted February 01 2012 - 09:15 AM

So i did all that and it works. But i get a black screen still. I heard that running the 64 bit would fix that but it didnt. Any ideas?

#18 ratty

ratty

    Double rainbow all the way

  • Ratty
  • 13284 posts

Posted February 01 2012 - 04:11 PM

Funny that we get random internet people finding this from google.
Anyway, if you get a black screen, the most common cause of that is if you install a mod but don't delete the META-INF folder inside the minecraft.jar. I've never heard of upgrading fixing blackscreens on startup, usually 64-bit java helps with out of memory errors.

Another thing I found is you don't have to do all of that startup options stuff, when you install 64-bit java it will just use it. I can verify that in the task manager, there is no *32 next to javaw.exe.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users