Jump to content
Sign in to follow this  
ratty

How to record a demo (discussion)

Recommended Posts

I have a couple of questions here.

 

1)In this demo, at about tick 86000, you can see that the last cap is in flames even when it's not capped yet. Is this a glitch of some sort?

 

2)In the said demo(same tick), Rat With A Rifle earned himself the Banner Of Brothers achievement. However, the demo doesn't seem to show the achievements that players earned in-game. Any idea how to make this work?

Share this post


Link to post

I have a couple of questions here.

 

1)In this demo, at about tick 86000, you can see that the last cap is in flames even when it's not capped yet. Is this a glitch of some sort?

 

I didnt look at the demo file, but I see it in that video you made, I believe that is caused from skipping around the demo, try playing it from the beginning and just letting it reach that tick at fast speed rather than skipping to a certain part. Skipping to a tick also can cause sprays to not show up too. I hope that was the problem, because I have no idea otherwise.

 

2)In the said demo(same tick), Rat With A Rifle earned himself the Banner Of Brothers achievement. However, the demo doesn't seem to show the achievements that players earned in-game. Any idea how to make this work?

 

No idea, but you won't see those achievement earned messages if you're in spectator too.

Share this post


Link to post

does anyone know a way to hide the panel in the center of the screen with the name/health of the player you're spectating?

Share this post


Link to post

there's a way posted to disable all huds...but I guess you still wanna have the killbar and the lifehud... actually I do wanna know that too...that'd be sweet

Share this post


Link to post

there's a way posted to disable all huds...but I guess you still wanna have the killbar and the lifehud... actually I do wanna know that too...that'd be sweet

 

I figured out one better, I managed to keep it but move it to the bottom of the screen. I think i'll probably leave it this way for normal gameplay too.

 

this is the file that i changed, place it in [...]\team fortress 2\tf\scripts\ (if it doesn't exist just make the folder). You may need to fiddle with it depending on your resolution, the relevant number to change is under the section "CSpectatorTargetID", next to "ypos". the default is 250, i upped it (which moves it downward, derp) to 385, which (for me) places the little plate just above the objective display (capture points/cart progress).

 

if you want to get rid of it entirely, just enter a really high number, it'll just place it completely offscreen.

 

[edit]whoops, wont let me upload the .res file. figuring out somewhere to put it...

[doubleedit]i are so smart, i can just zip it

hudlayout.zip

Share this post


Link to post

Regarding hiding the panel that shows what weapon people are carrying, they added it to the options in TF2.

Options -> Multiplayer -> Advanced -> "Show nonstandard items on spectated players".

Share this post


Link to post

Hmm, I do the record to AVI method for videos. Anyways I hadn't tried to make a video in a few months and when I tried last time, it said that windows media player doesn't support the codec that I'm using. What's up with this D:

Share this post


Link to post
'" data-cid="116782" data-time="1283313814" data-date="August 31 2010 - 10:03 PM">

Hmm, I do the record to AVI method for videos. Anyways I hadn't tried to make a video in a few months and when I tried last time, it said that windows media player doesn't support the codec that I'm using. What's up with this D:

 

First make sure WMP is up to date.

 

And if that doesnt work, reinstall the codec, and make sure everything under 'Supported video codecs' and 'supported audio codecs' is checked.

Share this post


Link to post

So I followed the instructions in the thread like I've done before with another video.

 

Strangely, my result is a weird black and white video, slightly slanting to the right, with a duplicate slanting next to it on the left to fill a gap. It's like watching the game through a security camera.

 

What did I do wrong?

Share this post


Link to post

So I followed the instructions in the thread like I've done before with another video.

 

Strangely, my result is a weird black and white video, slightly slanting to the right, with a duplicate slanting next to it on the left to fill a gap. It's like watching the game through a security camera.

 

What did I do wrong?

 

I got that before. Can't remember what fixed it. Maybe changing the compression ratio?

Share this post


Link to post

I don't get how to understand the names of the demos on the site,like with all the random numbers,they confuse me. :/ Im new so thats pretty much why im dumb and dont know.

Share this post


Link to post

I'll just pull a random one I'm using.

 

auto-20100905-1612-cp_steel.dem

 

The first set of numbers is the date. This one is from 2010, September 5th. The next is the time using a 24-hour clock, so this one was recorded at 4:12pm Pacific.

 

there you go

Share this post


Link to post

So I followed the instructions in the thread like I've done before with another video.

 

Strangely, my result is a weird black and white video, slightly slanting to the right, with a duplicate slanting next to it on the left to fill a gap. It's like watching the game through a security camera.

 

What did I do wrong?

 

Try this. On the encoder configuration, hit presets, load all, default. This will revert the codec to it's default settings. Then go back and change everything like it tells you in the video (Encoder, Mode, bitrate) and leave everything else alone.

Posted Image

Share this post


Link to post

I'll just pull a random one I'm using.

 

auto-20100905-1612-cp_steel.dem

 

The first set of numbers is the date. This one is from 2010, September 5th. The next is the time using a 24-hour clock, so this one was recorded at 4:12pm Pacific.

 

there you go

 

Oh wow,thanks.

Share this post


Link to post

Ok, new problem.

 

That one Scout rush video I made was about 66mb. It's also 2:16 minutes.

 

This new video I got is only 24 seconds or so. It hit 2.4gb.

 

how did i do that

 

Nothing is different in settings. I think.

Share this post


Link to post

Fantastic. I went to save it as an AVI again in an attempt to compress it this time around (I realized I didn't actually select a compression), and I'm getting the black/white slanting video effect again.

 

I know it's something up with the ffdshow, but I can't figure out what.

 

edit: This is starting to piss me off; I can't figure out why this codec is doing this to me. Someone please help me.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×